A Practical Guide to SharePoint 2013

A Practical Guide to SharePoint 2013
A Practical Guide to SharePoint 2013 - Book by Saifullah Shafiq

Sunday, January 5, 2014

SharePoint 2013 - Web Part Properties are disabled

Are you wondering where web part properties have gone in SharePoint 2013? Have you given up after searching for clues in Google? You add a web part to the page but you are unable to edit it because properties are nowhere to be seen. All you see is an arrow that shows/hides the web part. You are unable to select the web part on the page! Ok, the reason for all these symptons is the browser. I started facing this problem all of a sudden. The only thing I remember I did before this problem started was installing a cummulative update for SharePoint. I thought the update has messed permissions somehow so I tried to fix those as well but all in vain. Finally, I opened SharePoint 2013 site in Chrome and it was working fine, I could see the web part properties. That made me think about the IE and I checked the version, it was 11. Upon checking updates in the Control Panel, I found out that a recent update had installed IE11 on the machine. Automatic updates are enabled on my server and I was using this server after a long time. The previous version installed was IE9. I uninstalled the update that installed IE11, restarted the server and web part properties are back. I am sharing this because I couldn't find a clue on the search engines. So, if you are in the same situation, check your browser version and revert back to the version that was working.